No inbound/outbound calls

Incident Report for Evolve IP EU

Resolved

This incident has been resolved.
Posted May 23, 2025 - 14:19 CEST

Monitoring

A fix has been implemented by our vendor. Preliminary results are positive. While we continue to monitor the results, please check to see if the issue is resolved. If you still experience the issue, please reach out to our Support team.
Posted May 23, 2025 - 11:52 CEST

Investigating

We are aware of an issue with inbound and outbound calls, impacting some of our OCC Cloud Azure customers.

We are investigating this issue with high priority alongside our vendor and will provide updates as soon as more information becomes available.
Posted May 23, 2025 - 10:35 CEST
This incident affected: OCC Online Contact Center (OCC Cloud).