Unable to navigate to Touchpoint URL
Incident Report for Evolve IP EU
Resolved
This incident has been resolved.
Posted Apr 18, 2024 - 12:01 CEST
Monitoring
We have received reports that some users are unable to navigate to the Touchpoint URL.

To solve this, we advise you to clear the browser cache, close the browser completely, and retry. This should fix the issue.
Posted Apr 18, 2024 - 08:57 CEST
This incident affected: OCC Online Contact Center (OCC Cloud).